“애플A칩 결함, 아이폰X 패치 불가능한 취약점에 노출”

가 +
가 -

카네기멜론 대학 CERT 협력 센터(CERT Coordination Center)는 12월19일(현지시간) A5칩부터 A11칩까지 애플이 자체 설계한 두뇌 칩이 탑재된 아이폰과 아이패드, 애플워치 등 주요 제품에서 취약점이 발견됐으며 주의가 요구된다고 밝혔다. 아이폰4S를 포함해 아이패드2와 지난 2017년 나온 아이폰X 사용자까지 부정적인 영향을 초래할 수 있다.

| 아이폰4S와 아이패드2에 탑재된 ‘애플 A5’

JPCERT/CC에 따르면 이번에 발견된 ‘UAF(use-after-free)’ 취약점은 메모리 해제 후 재사용에 대한 것으로, 메모리를 사용한 뒤 해제한 후에도 공격자가 이 메모리 영역을 계속 사용할 수 있는 결함이다. 문제는 이 결함이 시큐어롬(SecureROM)에서 발견됐다는 점이다. 시큐어룸은 읽기 전용으로 설정되어 있다. 따라서 여기서 발견된 결함은 소프트웨어나 펌웨어 업데이트 형태로는 패치가 불가능하다. 애플이 이번 결함에 딱히 제공할 수 있는 대책이 없다는 의미다.

JPCERT/CC는 이번 취약점에 영향을 받을 수 있는 애플 제품을 함께 공개했다. 아이폰은 2011년 나온 아이폰4S부터 10주년 아이폰X이 해당된다. 아이패드는 2세대부터 7세대까지이고 ▲아이패드 미니 2-3세대 ▲아이패드 에어, 아이패드 에어2 ▲아이패드 프로 10.5인치, 12.9인치(2세대) ▲애플워치 시리즈1-3 ▲3세대 애플TV ▲애플TV 4K ▲아이팟터치 5-7세대가 포함된다.

A12 이상 칩이 탑재되는 아이폰XS, 아이폰XR, 아이폰11 시리즈, 아이패드 프로 12.9인치(3세대)는 해당되지 않는다.

이번 결함에 대해 JPCERT/CC는 “아이폰 등의 애플 기기를 컴퓨터에 연결하고 펌웨어 업데이트(DFU) 모드로 전환된 상태에서 노출되므로 일반 사용자가 직접적으로 영향을 받을 가능성은 낮다”라면서도 “해당 기기 사용자는 해커의 공격에 노출되지 않도록 페이스ID와 터치ID, 암호 같은 기기를 보호하는 잠금장치를 활성화해둬야 한다”라고 강조했다.

네티즌의견(총 0개)