맥PC로 '연말정산' 도전기

발행일 2013-01-23 15:15:59
올해도 어김없이 연말정산 시즌이 다가왔습니다. 매년 하는 연말정산이지만 올해는 기분이 좀 다릅니다. 지난해까지만 해도 윈도우 운영체제(OS)가 깔린 노트북에서 인터넷 익스플로러(IE) 웹브라우저를 통해 연말정산에 필요한 서류를 내려받았습니다. 올해는 맥 OS X 마운틴 라이언이 깔린 맥북에어에서 사파리 웹브라우저를 이용해 연말정산간소화 웹사이트를 이용할 생각입니다.

국세청은 2010년부터 다양한 웹브라우저와 OS에서 연말정산 서비스를 이용할 수 있다고 밝힌 바 있습니다. 행정안전부는 2009년 공공기관 온라인 서비스 호환성 조사를 통해 국세청을 비롯한 47개 기관의 홈페이지에 웹표준 준수를 권고했고, 국세청은 액티브X를 사용하던 공인인증서 로그인 등의 프로그램을 자바 기반으로 바꿨습니다. 연말정산 간소화 서비스를 윈도우-IE가 아닌 환경, 즉 맥과 리눅스 OS는 물론 사파리와 파이어폭스 등 다양한 웹브라우저에서도 접근할 수 있게 됐단 얘기지요.

국세청이 웹표준 기반의 연말정산 간소화 서비스를 선보이겠다고 한 지 3년이 돼 갑니다. 그럼에도 저 같은 맥 사용자들은 PC방을 찾거나 가상화 솔루션을 이용해 연말정산을 해야 한다고 페이스북이나 트위터를 통해 불만을 토로하고 있습니다. 그런데, 정말로 맥에서 IE가 아닌 웹브라우저로 온말정산간소화 서비스를 이용할 수 있을까요? 웹표준을 준수하는 연말정산간소화 웹사이트엔 어떤 일이 생긴 걸까요?

윈도우는 멀티브라우저 지원, 맥·리눅스는 아직

저는 '마운틴 라이언'이라고 불리는 맥OS X 10.8.2 사용자 입니다. 웹브라우저는 사파리 6.0.2와 크롬 24.0.1312.52을 사용하고 있지요.

먼저 국세청이 공식으로 지원한다는 사파리 웹브라우저를 통해 연말정산간소화 웹사이트를 방문했습니다. 연말정산간소화 웹페이지 첫 화면이 뜹니다. '소득공제자료 조회/출력' 메뉴를 마우스로 누르기 무섭게 키보드 보안 프로그램 설치 안내창이 뜹니다. 연말정산간소화 서비스를 쓰려면 공인인증서로 로그인을 해야 합니다. 그런데 공인인증서에서 암호를 입력하려면 해킹 방지를 위해 보안 프로그램을 먼저 설치해야 합니다. '승인'을 눌렀습니다.



'클라이언트 키퍼 키프로(Client Keeper Keypro)'라는 키보드보안 프로그램을 설치해야 하는군요. 그런데 뭔가 좀 이상합니다. 웹사이트에 게재된 안내 문구를 따라 설치하려 해봐도 도통 설치가 안 됩니다. 분명 32비트 맥 OS 10.5.×~ 맥 OS 10.5.8/ 사파리 3.14 이상을 지원한다고 설명돼 있습니다. 키보드 보안 프로그램 설치를 원하지 않을 경우 안내문 하단에 위치한 '설치하지 않고 진행' 버튼을 클릭해 진행할 수 있다고 나와 있지만, 이 또한 먹통입니다. 보안 프로그램이 설치되는 것도, 그렇다고 설치가 안되는 것도 아닌 어정쩡한 상태가 계속됩니다.

참다못해 페이지 새로고침을 눌러 연말정산간소화 웹사이트 화면으로 돌아갔습니다. 이번에는 키보드 보안 프로그램을 설치하지 않을 생각이었지요. 아까 마주한 화면에 '설치하지 않고 진행' 단추가 있었으니, 설치를 안해도 되겠지요.



'취소'를 누르자 웹암호 보안프로그램 설치 중이란 문구가 뜨면서 저절로 '멀티브라우저를 위한 매직라인V4.0(MagicLine V4.0 for MultiBrowser)'이 설치됩니다. 공인인증서 가입자 소프트웨어 설치목록 구성, 공인인증서 가입자 소프트웨어 다운로드, 공인인증서 가입자 소프트웨어 검증, 공인인증서 가입자 소프트웨어 설치 과정을 보아하니, 공인인증서 실행을 위해 마련된 또 다른 보안프로그램인가 봅니다.



설치가 끝나고, 기다렸던 화면이 뜹니다. 연말정산간소화 서비스를 이용하기 위한 맨 마지막 단계 '공인인증서'를 이용한 로그인 절차입니다. 공인인증서가 담긴 USB 메모리를 꽂고 주민번호와 인증서 암호를 입력했습니다. 이제 조금만 더 기다리면 맥에서도 간소화 서비스를 이용할 수 있다는 생각도 잠깐, 인증서 암호를 입력하기가 무섭게 '처리결과 안내'라는 창이 뜨면서 '이용자의 전자서명 검증에 실패했습니다'라는 문구가 떴습니다. 왜 전자서명 검증에 실패했는지 이유도 알지 못한 채 소득공제 자료를 조회할 수도 출력할 수도 없습니다.



제 공인인증서가 문제인 걸까요? 64비트 윈도우7 환경에서는 거칠 게 없더군요. 공인인증서도, 키보드 보안프로그램도, 기타 보안프로그램도 무사 통과입니다. '승인'을 누르기 무섭게 거침없이 실행되고 설치됩니다. 앞서 맥에서 이용했던 것과 같은 공인인증서를 이용해 인증을 마쳤습니다. 인터넷 익스플로러(9.0.8112.16421), 파이어폭스(7.0.1와 12), 크롬(23.0.1231.97m와 24.0.1312.52.m) 등 다양한 웹브라우저에서 거침없이 연말정산 간소화 서비스를 누릴 수 있더군요.

윈도우 아닌 OS는 최신 버전 지원 안 돼

맥-사파리 환경뿐 아니라 맥-크롬에서도 비슷한 상황을 마주했습니다. 아니, 오히려 크롬은 더 상황이 좋지 않았다고 표현하는 게 맞겠군요.

크롬 웹브라우저에서는 "연말정산간소화서비스는 자바환경 기반으로 웹표준서비스를 제공하므로 자바프로그램이 정상적으로 설치돼야 연말정산간소화서비스 접속이 가능하다"라는 문구만 마주했습니다.



이미 맥에는 자바 최신 버전이 깔려 있는 상태였지만, 크롬 웹브라우저는 앞선 안내화면에서 더 이상 넘어가지 못하더군요. 자바 프로그램 수동 설치 단추를 눌러봐도, 자바 설치오류 조치방법 안내 단추를 눌러봐도 무엇하나 반응하지 않는 답답한 상황이 이어졌습니다.

웹표준에 따라 만들어진 웹사이트인데 왜 맥-사파리와 맥-크롬에서 이용할 수 없는지 궁금했습니다. 국세청 연말정산업무를 담당하고 있는 원천세과에 문의했습니다. 이상수 국세청 원천세과 조사관은 "연말정산간소화 서비스는 웹표준을 준수해 개발했다"라며 "윈도우와 맥, 리눅스에서 대표적으로 쓰이는 웹브라우저인 인터넷 익스플로러, 사파리, 파이어폭스를 지원한다"라고 설명했습니다.

제가 체험한 내용과는 거리가 있었습니다. 그래서 "제가 쓰고 있는 맥 OS X 10.8.2 버전과 사파리(6.0.2)에서는 되지 않는다"라고 다시 물었습니다. 이상수 조사관은 "확인해보고 연락주겠다"라고 대답하더군요.

기다렸습니다. 잠시 뒤 이상수 조사관은 "알아보니 공인인증성 해킹 감염 방지를 위해 설치를 요구한 보안 키보드 기능이 최신 맥 OS X을 지원하지 않아 이용할 수 없다고 한다"라며 "맥 OS X 10.5, 일명 레오퍼드 이하 버전에서만 국세청 연말정산간소화 웹사이트를 이용할 수 있다"라고 설명했습니다.

연말정산간소화 웹사이트를 이용하려면 키보드 보안 프로그램이 설치돼 공인인증성 유효성 검사를 마쳐야 하는데→불행히도 해당 키보드 보안 프로그램이 제가 사용하고 있는 운영체제를 지원하지 않아→공인인증서 유효성 검사를 통과하지 못한 탓에→연말정산간소화 서비스를 이용할 수 없다는 얘기였습니다.

국세청에 보안 키보드 프로그램을 제공한 루멘소프트 관계자는 "현재 연말정산 간소화 웹사이트에 플러그인된 키보드 보안 프로그램은 윈도우에서는 멀티브라우저를 지원하지만, 최신 버전의 맥과 리눅스 OS에서는 해당 키보드 보안 프로그램을 사용할 수 없다"라며 "개발 당시 최신 버전을 지원했는데, OS가 빠르게 판올림되는 탓에 완벽히 대응하지 못했으며, 지금 개발 중"이라고 설명했습니다.

실제로 맥 OS X 10.4.11(타이거)에 파이어폭스(3.6)을 사용하고 있는 동료는 연말정산 조회가 잘 된다고 말하더군요. 갑자기 최신 OS를 설치한 '설움'이 몰려왔습니다. 연말정산간소화 웹사이트에 지원하는 OS와 웹브라우저 버전을 표시해줬다면 억울함이 덜했을텐데 말이지요.

국세청이 웹표준을 따르는 서비스를 도입한 건 환영할 일입니다. 다만, 살짝 아쉬움은 남습니다. 키보드 보안 프로그램 설치 과정에서 '설치하지 않으면 공인인증서 유효화 검사를 통과하지 못해 연말정산 웹서비스를 이용할 수 없습니다'라는 문구라도 넣어줘 혼란을 방지했으면 더 좋지 않았을까요. 연말정산간소화 서비스를 쓰는 내내 '왜 난 사용할 수 없는가' 고개를 갸웃거린 사용자 입장에서 드리는 작은 민원입니다.

함께 보면 좋은 뉴스

댓글

(0)
※ 댓글 작성시 상대방에 대한 배려와 책임을 담아 깨끗한 댓글 환경에 동참에 주세요. 0 / 300

요일별 Edition